The directory of kernel headers (version @@VMWARE@@ UTS_RELEASE) does not match your running kernel

uname -a

is returning the right version 3.2.0-30-generic however the vmware tools script is complaining.

Solution to create a couple of symlinks

ln -s /lib/modules/3.2.0-30-generic/build/include/generated/utsrelease.h /lib/modules/3.2.0-30-generic/build/include/linux/utsrelease.h

ln -s /lib/modules/3.2.0-30-generic/build/include/generated/autoconf.h /lib/modules/3.2.0-30-generic/build/include/linux/autoconf.h

Then run the vmware perl script again

/vmware-install.pl 
Let's share thisShare on FacebookShare on Google+Tweet about this on TwitterShare on LinkedIn